查看: 14111|回复: 53
收起左侧

[原创资源] [17.9.10更新]修改smooth gestures扩展

  [复制链接]
p23571113
发表于 2012-6-21 13:05:28 | 显示全部楼层 |阅读模式
本帖最后由 p23571113 于 2017-9-10 14:15 编辑

17.9.10更新
修复chrome 61版本跳转页面顶部/底部失效的问题


Smooth Gestures 0.15.4.13.zip (273.86 KB, 下载次数: 54)

评分

参与人数 2经验 +40 人气 +1 收起 理由
samtogo + 30 + 1 版区有你更精彩: )
苏帅其实不帅 + 10 版区有你更精彩: )

查看全部评分

narutovsop
发表于 2012-6-21 13:07:11 | 显示全部楼层
感谢分享,不过我用的世界之窗极速版自带了鼠标手势,仅支持了
zlmljyl
发表于 2012-6-21 13:49:12 | 显示全部楼层
这个要顶   辛苦了
随风逸舞
发表于 2012-6-21 13:54:33 | 显示全部楼层
lz辛苦了,感谢分享
Amelia
发表于 2012-6-21 14:00:50 | 显示全部楼层
顶了。要是有人能做出内置的就更好了。
猥琐泡泡
发表于 2012-6-21 14:32:54 | 显示全部楼层
非常感谢楼主~~
zlmljyl
发表于 2012-6-21 14:33:49 | 显示全部楼层
干嘛不用最新版0.15.0.13 做呢   给你个链接  麻烦制作一下 我按你说的方法制作  总是无法打包????

http://bbs.kafan.cn/forum.php?mo ... D727%26typeid%3D727
p23571113
 楼主| 发表于 2012-6-21 14:47:58 | 显示全部楼层
zlmljyl 发表于 2012-6-21 14:33
干嘛不用最新版0.15.0.13 做呢   给你个链接  麻烦制作一下 我按你说的方法制作  总是无法打包????

http ...

要修改manifest.json, 你删掉的文件名不能出现在这个文件中
比如里面有这一段
  1. "content_scripts": [
  2.     {
  3.       "matches": [ "<all_urls>" ],
  4.       "js": [ "js/gestures.js","js/define.js","js/helpers.js","js/contentscript.js"],
  5.       "all_frames": true,
  6.       "run_at": "document_start"
  7.     },
复制代码
因为删去了define.js, helpers.js, contentscript.js这三个文件
所以要把这一段改为
  1. "content_scripts": [
  2.     {
  3.       "matches": [ "<all_urls>" ],
  4.       "js": [ "js/gestures.js"],
  5.       "all_frames": true,
  6.       "run_at": "document_start"
  7.     },
复制代码
其余的类似
zlmljyl
发表于 2012-6-21 20:08:52 | 显示全部楼层
p23571113 发表于 2012-6-21 14:47
要修改manifest.json, 你删掉的文件名不能出现在这个文件中
比如里面有这一段因为删去了define.js, help ...

试了N便  不知何故  无法打包。。。。。。
还是帮忙做一个   当个伸手党。。。。。。多谢
865bbs
头像被屏蔽
发表于 2012-6-21 21:50:06 | 显示全部楼层
strokeit路过
您需要登录后才可以回帖 登录 | 快速注册

本版积分规则

手机版|杀毒软件|软件论坛|优惠券| 卡饭论坛

Copyright © KaFan  KaFan.cn All Rights Reserved.

Powered by Discuz! X3.3( 苏ICP备07004770号 ) GMT+8, 2017-9-20 02:58 , Processed in 0.093153 second(s), 8 queries , MemCache On.

快速回复 返回顶部 返回列表