搜索
查看: 593|回复: 5
收起左侧

[系统] .Net framework 4.x有必要所有版本全都装吗?为什么Windows Update无法安装?

[复制链接]
chncwk
发表于 2017-9-9 07:02:26 | 显示全部楼层 |阅读模式
本帖最后由 chncwk 于 2017-9-9 07:04 编辑

每次Windwos Update都提示这三个版本是必须安装的,之前通过其他软件已装有4.51。
安装最新版本后,旧版本可以卸载吗?
未标题-1.png
点击安装后却出现643错误
未标题-2.png
查看详细信息不知所云。
未标题-3.png

chncwk
 楼主| 发表于 2017-10-16 09:33:30 | 显示全部楼层
重装系统后再试,要在第一时间用update装到4.7,不要等装了其他软件,过了若干天再试。
大版本号相同的可以只装最新版,比如装了4.7就可以删掉之前更新的4.0、4.51、4.6了。
据说要删掉低版本号的才能手动安装高版本号,还没有试过……
mrdou
发表于 2017-10-16 18:10:41 来自手机 | 显示全部楼层
有的软件还需要低版本
runtime
发表于 2017-10-16 19:05:08 | 显示全部楼层
新版本包含兼容旧版本的,安装最新的.net 4.x就行了。
jr21066
发表于 2017-10-16 20:40:52 | 显示全部楼层
装最新的.如果有特别旧的软件不认识.一般是可以通过修改注册表里的版本号解决的
52158110
发表于 2017-10-16 21:12:20 | 显示全部楼层
只装最新的4.7版就可以了。
您需要登录后才可以回帖 登录 | 快速注册

本版积分规则

手机版|杀毒软件|软件论坛|优惠券| 卡饭论坛

Copyright © KaFan  KaFan.cn All Rights Reserved.

Powered by Discuz! X3.4( 苏ICP备07004770号 ) GMT+8, 2017-11-20 03:34 , Processed in 0.054785 second(s), 8 queries , MemCached On.

快速回复 返回顶部 返回列表