搜索
楼主: 记录微笑
收起左侧

[病毒样本] 自制勒索20190725

[复制链接]
记录微笑
 楼主| 发表于 2019-7-27 07:44:27 | 显示全部楼层
yjwfdc 发表于 2019-7-26 23:02
是不是两次xor=没加密

我估摸着应该是没加密的文件。
我没调加密顺序,加上不改后缀,导致要等很长时间才能看到明显位置被加密,而且重启程序后从头开始重新加密。
cocomail
发表于 2019-7-27 08:07:19 | 显示全部楼层
记录微笑 发表于 2019-7-27 07:44
我估摸着应该是没加密的文件。
我没调加密顺序,加上不改后缀,导致要等很长时间才能看到明显位置被加密 ...

你随便拍张照片,加密后传上来看看我能否解密
记录微笑
 楼主| 发表于 2019-7-27 08:29:37 | 显示全部楼层
cocomail 发表于 2019-7-27 08:07
你随便拍张照片,加密后传上来看看我能否解密

不用了,待会我自己用算法连续加密两次不就知道了。
yjwfdc
发表于 2019-7-27 09:11:09 | 显示全部楼层
记录微笑 发表于 2019-7-27 07:44
我估摸着应该是没加密的文件。
我没调加密顺序,加上不改后缀,导致要等很长时间才能看到明显位置被加密 ...

如果用的是xor,那就是两次等于无。
记录微笑
 楼主| 发表于 2019-7-27 10:20:43 | 显示全部楼层
yjwfdc 发表于 2019-7-27 09:11
如果用的是xor,那就是两次等于无。

没你想得那么复杂,我用的是易语言自带的RC4加密算法
yjwfdc
发表于 2019-7-27 13:05:27 | 显示全部楼层
记录微笑 发表于 2019-7-27 10:20
没你想得那么复杂,我用的是易语言自带的RC4加密算法

百度了一下,rc4用的是xor
记录微笑
 楼主| 发表于 2019-7-27 13:09:21 | 显示全部楼层
yjwfdc 发表于 2019-7-27 13:05
百度了一下,rc4用的是xor

好吧,下次换成不对称加密的方法
yjwfdc
发表于 2019-7-27 13:14:00 | 显示全部楼层
记录微笑 发表于 2019-7-27 10:20
没你想得那么复杂,我用的是易语言自带的RC4加密算法
  1. .版本 2
  2. .支持库 dp1
  3. .支持库 spec

  4. .程序集 窗口程序集_启动窗口

  5. .子程序 __启动窗口_创建完毕
  6. .局部变量 结果, 字节集
  7. .局部变量 数据, 字节集

  8. 数据 = { 14, 521, 52, 1, 5, 21, 5, 5, 2, 33, 455, 1, 45, 52, 15, 5, 1, 55, 2898, 98, 6, 5, 67 }
  9. 结果 = 加密数据 (数据, “要大规模副教授人”, #RC4算法)
  10. 调试输出 (结果)
  11. 结果 = 加密数据 (结果, “要大规模副教授人”, #RC4算法)
  12. 调试输出 (结果)
  13. .如果真 (结果 = 数据)
  14.     调试输出 (“相同”)
  15. .如果真结束

  16. 测试了一下,rc4两次等于没加密。
复制代码


yjwfdc
发表于 2019-7-27 13:18:02 | 显示全部楼层
记录微笑 发表于 2019-7-27 13:09
好吧,下次换成不对称加密的方法

换成 DES算法 就可以了。
您需要登录后才可以回帖 登录 | 快速注册

本版积分规则

手机版|杀毒软件|软件论坛|卡饭乐购| 卡饭论坛

Copyright © KaFan  KaFan.cn All Rights Reserved.

Powered by Discuz! X3.4( 苏ICP备07004770号 ) GMT+8, 2019-10-17 06:20 , Processed in 0.064362 second(s), 16 queries .

快速回复 返回顶部 返回列表